איזה חבילות בסיס מוצגות בשרת Cloudways?

שרתי Cloudways מגיעים עם כמה חבילות שונות והרחבות כברירת מחדל כדי לשפר את הביצועים של האתר ולשמור על היציבות שלו. השרת מגיע עם הפצת Debian 9 כברירת מחדל. במאמר נספק גם מידע על האופן בו ניתן לבדוק ולאמת את ה-Debian 9 כדי שיהיה זמין בכל השרתים שהושקו לאחר 11 בספטמבר 2019. כל שרתי Cloudways מגיעים עם חבילות ברירת שונות והרחבות ליצור שיווי משקל בין הביצועים והיציבות של האתרים שלכם.

אלו הן חבילות הבסיס הזמינות בשרת Cloudways

Nginx

פלטפורמת Cloudways מגיעה עם שרת אינטרנט בשם Nginx כחלק מחבילת האינטרנט המוגדרת כברירת מחדל. כל שרתי הענן של Cloudways מצוידים ב-Nginx חזקים לשרת בקשות תוכן סטטי. זה עוזר לשרת יותר קהלים במהירות תוך הפחתת העומס על השרת שלכם מכיוון שהוא זקוק למשאבים מינימליים. הגרסה הזמינה כעת של Nginx היא 1.19.x, והיציאות הזמינות הן 80 ו- 443.

כיצד לאמת את גרסת Nginx?

  1. כדי לאמת את גרסת Nginx התחברו לשרת שלכם דרך SSH
  2. ברגע שאתם מחוברים, בצעו את הפקודה הבאה כדי להציג את הפרטים:
כיצד לאמת את גרסת Nginx?

Varnish

פלטפורמת Cloudways מציעה את Varnish בצורה מובנית כחלק מהאופטימיזציה של הפלטפורמה. התוסף מטמון הזה מאיץ HTTP בקוד פתוח המיועד לאתרים דינמיים במטמון ובמסירת בקשות תוכן סטטיות ודינמיות. הגרסה הזמינה כרגע היא 5.0.x. זה עובד מצוין עם Nginx ו- Apache כדי לספק חוויה מעולה למבקרים באתר שלכם.

איך לאמת גרסת Varnish?

  1. כדי לאמת את גרסת Varnish התחברו לשרת שלכם דרך SSH
  2. ברגע שאתם מחוברים, בצעו את הפקודה הבאה כדי להציג את הפרטים:
איך לאמת גרסת Varnish?

Apache

אפאצ'י הוא שרת אינטרנט HTTP ידוע והוא פותח ומתוחזק על ידי קרן אפאצ'י. פלטפורמת Cloudways כוללת גם שרת אינטרנט של אפאצ'י מהיר. אפאצ'י ידוע בזכות האמינות, התאימות והמגוון המרשים של התכונות שלו. הגרסה המותקנת היא Apache 2.4.x עבור שרתי דביאן 9.

איך לאמת גרסת Apache?

  1. כדי לאמת את גרסת Varnish התחברו לשרת שלכם דרך SSH
  2. ברגע שאתם מחוברים, בצעו את הפקודה הבאה כדי להציג את הפרטים:
איך לאמת גרסת Apache?

Apache Modules - מודלים של Apache

מרבית המודלים מוגדרים כברירת המחדל וזמינים בשרתים. ניתן לבקש מודולים שאינם מופעלים כברירת מחדל על ידי פנייה לצוות התמיכה של Cloudways.

להלן רשימת המודולים הנפוצים ביותר של אפאצ'י:

Apache Modules - מודלים של Apache

מאגר מידע - Database

השירותים כוללים את MariaDB 10.1 כמאגר ברירת מחדל של אתר האינטרנט שלכם; עם זאת, אתם יכולים לשדרג את גרסת מסד הנתונים ל- MariaDB 10.2, MariaDB 10.3 או MariaDB 10.4 בהתאם לדרישות שלכם. תוכלו גם לאמת ולראות את כל גרסאות מסד הנתונים הזמינות באמצעות פלטפורמת Cloudways.

מדוע Cloudways מציעה את MariaDB ולא את MySQL?

MariaDB היא גרסה מתקדמת ותחליף תואם לגרסת MySQL המקבילה. 

Memcached

Memcached היא מערכת מטמון המשמשת לזרז אתרי אינטרנט דינמיים על ידי אחסון נתונים בזיכרון השרת לזמן מוגבל כדי להקל על העומס על מסד הנתונים. הגרסה המותקנת של Memcached היא 1.4.x.

איך לאמת גרסת Memcached?

  1. כדי לאמת את גרסת Varnish התחברו לשרת שלכם דרך SSH
  2. ברגע שאתם מחוברים, בצעו את הפקודה הבאה כדי להציג את הפרטים:
איך לאמת גרסת Memcached?

PHP

השרת החדש שלכם מוגדר לשימוש ב- PHP 7.3 כברירת מחדל. ניתן לשדרג או להחליף לגרסה אחרת באמצעות פלטפורמת Cloudways. הגרסאות הזמינות של PHP כוללות PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 ו- 8.0. הגרסה האחרונה היא PHP 8.0, הדורשת דביאן 9 לכל הפחות. זה לא תואם ל- Debian 7 ו- Debian 8. אתם יכולים גם לבדוק את תאימות האתרים שלכם עם גרסאות PHP זמינות שונות.

איך לאמת גרסת PHP?

  1. כדי לאמת את גרסת Varnish התחברו לשרת שלכם דרך SSH
  2. ברגע שאתם מחוברים, בצעו את הפקודה הבאה כדי להציג את הפרטים:
איך לאמת גרסת PHP?

הרחבות / מודולים של PHP

מספר גדול של סיומות / מודולים של PHP מותקנים על פי גרסת ה- PHP שנבחרה. ניתן לבקש סיומות / מודולים של PHP שאינם מופעלים כברירת מחדל על ידי פנייה ל-Cloudways.

PHP 5.6.x Extensions – גרסה זו תומכת ב- ZendGuard ו- xDebug שניתן להפעיל מהגדרות השרת.

PHP 7.0.x Extensions – גרסה זו תומכת ב- xDebug שניתן להפעיל אותה מהגדרות השרת. ZendGuard אינו נתמך בגרסת PHP זו.

PHP 7.1.x Extensions – גרסה זו תומכת ב- xDebug שניתן להפעיל אותה מהגדרות השרת. ZendGuard אינו נתמך בגרסת PHP זו.

PHP 7.2.x Extensions – גרסה זו תומכת ב- xDebug שניתן להפעיל אותה מהגדרות השרת. ZendGuard אינו נתמך בגרסת PHP זו.

PHP 7.3.x Extensions – גרסה זו אינה תומכת ב- Zendguard ו- xDebug.

PHP 7.4.x Extensions – גרסה זו אינה תומכת ב- Zendguard ו- xDebug.

PHP 8.0.x Extensions – גרסה זו תומכת ב- xDebug שניתן להפעיל אותה מהגדרות השרת. ZendGuard ו- IonCube אינם נתמכים כרגע בגרסת PHP זו.

מודולים / הרחבות נוספים של PHP

המודולים / הרחבות הבאים מותקנים לצד המודולים / הרחבות הסטנדרטיים:

מודולים / הרחבות נוספים של PHP
כל מה שחדש בוורדפרס